Bug #260

WAN port won't DHCP successfully (it would not receive packets, but would transmit them)

Added by Jim Gettys over 2 years ago. Updated almost 2 years ago.

Status:Closed Start date:09/01/2011
Priority:High Due date:
Assignee:David Taht % Done:

0%

Category:Networking Spent time: 0.50 hour
Target version:1st Usable CeroWrt release

Description

In smoketest 4 of RC6, the WAN port would not DHCP on my local network; which is a bit of a mess.

It was plugged into a DLINK DGS-2208 Gigabit switch, which is plugged into a 100Mbit switch, which is plugged into a WNDR3700v2 (running the Bismark build).

Hypothesis: it might have problems if it sees ethernet pause frames. I first became aware of pause frames when I saw them in a wireshark capture I took off this switch last fall.

My laptops dhcp off this switch just fine, FWIW.


Related issues

related to Cerowrt - Bug #258: rc6-smoketest2 doesn't route through ge00 right Closed 08/31/2011

History

Updated by Jim Gettys over 2 years ago

This problem appears to be present still in real RC6. Plugged directly into the router serving as my home router, it dhcp's on the wan port fine and works.

Updated by Dave Täht over 2 years ago

We need to find a way to reproduce this in front of a developer that has this switch AND problem.

I was unable to reproduce in a similar environment.

Updated by Jim Gettys over 2 years ago

OK, I'll get a new switch ordered so that I can take the existing one that seems to trigger it out of service (mercifully), and we can reproduce it in front of someone able to debug it.

Updated by Jim Gettys over 2 years ago

Weirder and weirder. I thought that the switch in question was a 100Mbit switch; instead, it's a netgear 108p (8 port 10/100/1000Mbit POE switch). Additionally, I have another level of switching beyond this (a d-Link 2208). So I need to do a bit more debugging, and plug the router one step back (directly into the netgear) first to confirm at what level the problem is.

Updated by Dave Täht over 2 years ago

I'll argue it's at the number of levels it's at... rule of thumb: never connect more than 3 switches together.

Updated by Jim Gettys over 2 years ago

Yeah, but the factory firmware coped ok, when I tried it before.

I'll do a more systematic round of tests in the morning.

Updated by Dave Täht almost 2 years ago

  • Category set to Networking
  • Status changed from New to Closed

so far as I know this hasn't been a problem in months.

Also available in: Atom PDF