Feature #303

Samba badly needs updating....

Added by Jim Gettys over 2 years ago. Updated about 2 years ago.

Status:Closed Start date:11/18/2011
Priority:Normal Due date:
Assignee:Dave Täht % Done:

0%

Category:Openwrt Spent time: 6.50 hours
Target version:1st Usable CeroWrt release Estimated time:24.00 hours

Description

The samba in OpenWrt is antique and unmaintained.

Since we likely need it to help bridge between multiple sub-networks for Windows clients, this is bad... And doesn't support modern authentication methods for window.


Related issues

related to Cerowrt - Bug #314: Samba/Wins and windows XP and vista issues with wireless ... New 12/01/2011
duplicated by Cerowrt - Feature #302: Samba badly needs updating.... Closed 11/18/2011

History

Updated by Dave Täht over 2 years ago

The latest versions of samba are at 3.61, and the resulting software
per-requisites and binaries are huge.

What can be stripped out remains to
be seen.

There was a great deal of churn in the samba 3.0.X package of late,
which just stabilized, but I'm unsure if that will help any.

All we need is working wins support but whether that can be made to
work with the most current windows remains to be seen.

Updated by Dave Täht over 2 years ago

This work on 3.6 and the ongoing work on the 3.0 release are very encouraging.

https://dev.openwrt.org/ticket/9992

Updated by Dave Täht over 2 years ago

I have folded the latest work from the openwrt universe into the ceropackages repository.

Updated by Dave Täht over 2 years ago

I have stuck this version into cerowrt by default and updated luci to be able to use it.

As for this being a correct configuration - no, needs work.

Updated by Dave Täht about 2 years ago

  • Status changed from New to Closed
  • Target version changed from Cerowrt-1.0-rc8 to 1st Usable CeroWrt release

samba 364 is in the current releases.

smbpasswd will crash if you don't have an equivalent user in /etc/passwd, but that's about it. Well, wins needs to be enabled.

Also available in: Atom PDF