Bug #444

IPV6 configureation

Added by David Hunnisett on Jun 20, 2014. Updated on Jun 24, 2014.
Closed Normal Dave Täht

Description

Hi
I get a /64 from my ISP
SE00 gets given the entire /64
so neither SW10 or sw00 get any ipv6 addresses or assignments
how can I get ipv6 running on the wireless as well ?
Do I need a larger assignment from my ISP ?

/etc/config/network looks like:

config interface ‘se00’
option ifname ‘se00’
option proto ‘static’
option netmask ‘255.255.255.224’
option ip6assign ‘64’
option ipaddr ‘192.168.254.1’
option delegate ‘0’

config interface ‘ge00’
option ifname ‘ge00’
option _orig_ifname ‘ge00’
option _orig_bridge ‘false’
option proto ‘pppoe’
option username ‘xxx
option password ‘xxxxxxx’
option ipv6 ‘1’

config interface ‘wan6’
option ifname ‘@ge00’
option proto ‘dhcpv6’
option broadcast ‘1’
option metric ‘2048’
option reqprefix ‘60’
option reqaddress ‘try’

config interface ‘sw00’
option proto ‘static’
option netmask ‘255.255.255.224’
option ipaddr ‘192.168.254.65’
option ip6assign ‘64’

config interface ‘sw10’
option proto ‘static’
option netmask ‘255.255.255.224’
option ipaddr ‘192.168.254.97’
option ip6assign ‘64’

only

History

Updated by Dave Täht on Jun 24, 2014.
yes you need a /61 or better from your isp. (cero requests a /60 by default)

Failing that you can bridge your wifi to the ethernet which is what openwrt basically does, or use nd proxying, or use ipv6 dhcp throughout to say, use /67s instead of /64s (which will disable SLAAC).

This is a static export of the original bufferbloat.net issue database. As such, no further commenting is possible; the information is solely here for archival purposes.
RSS feed

Recent News & Articles

Sep 6, 2018 Wiki page
Pete Heist's Thoughts on ECN
Sep 5, 2018 Wiki page
Dave Taht's Stance on ECN
Sep 4, 2018 Wiki page
Jonathan Morton's Take on ECN
Sep 3, 2018 Wiki page
ECN-Sane Project
Aug 24, 2018 Wiki page
ECN-Sane Project

Find us elsewhere

Bufferbloat Mailing Lists
#bufferbloat on Twitter
Google+ group
Archived Bufferbloat pages from the Wayback Machine

Sponsors

Comcast Research Innovation Fund
Nlnet Foundation
Shuttleworth Foundation
GoFundMe

Bufferbloat Related Projects

Congestion Control Blog
Lede Project (OpenWrt)
Flent Network Test Suite
Sqm-Scripts
The Cake shaper
AQMs in BSD
IETF AQM WG

Network Performance Related Resources


Jim Gettys' Blog - The chairman of the Fjord
Toke's Blog - Karlstad University's work on bloat
Voip Users Conference - Weekly Videoconference mostly about voip
Candelatech - A wifi testing company that "gets it".